CONHEÇA TODO O PODER DAS FÓRMULAS ÍNDICE E CORRESP

No post de hoje vamos falar sobre duas fórmulas que sozinhas não tem muita utilidade, mas juntas são poderosas. Estou falando das fórmulas INDICE e CORRESP. Com a junção das duas temos uma espécie de PROCV ou PROCH, sem a necessidade de o valor procurado estar na primeira linha ou coluna.

Primeiro vamos vê-las em separado apenas para você entender como cada uma funciona.

FÓRMULA ÍNDICE

A fórmula ÍNDICE retorna o valor de uma célula específica de acordo com a linha e coluna especificadas. Vamos ver isso em um exemplo para ficar mais claro:
 

Aqui, queremos retornar a data que está em destaque; vamos ver como isso funcionaria com a fórmula ÍNDICE.

A fórmula tem 3 argumentos.

Matriz: aqui selecionamos todo o intervalo de informações;

Núm_linha: aqui colocamos o número da linha onde está a informação procurada;

Núm_coluna: aqui colocamos o número da coluna onde está a informação. *essa informação é opcional caso você selecione apenas uma coluna*.

Então nossa fórmula ficou da seguinte forma: =ÍNDICE(A:C;6;3)

E veja que o resultado é exatamente a data que está demarcada.

FÓRMULA CORRESP

Vamos agora ver a fórmula CORRESP. Diferente da índice, ela nos retorna em qual posição se encontra a informação procurada. A fórmula corresp tem 3 argumentos:

Valor_procurado: qual a informação que estamos procurando;

Matriz_procurada: selecionamos a linha ou coluna onde está a informação;

Tipo_correspondência: aqui temos três opções, mas para efeitos de praticidade, sempre iremos usar a opção 0 para buscarmos uma informação exata.

Então aqui estamos procurando a data que está na célula E4 na coluna C; e o 0 no final para garantir que vamos buscar a informação exata. A fórmula ficou da seguinte forma:

=CORRESP(E4;C:C;0)

Então o que a fórmula corresp fez foi passar por cada uma das células da coluna C e só parou quando encontrou a data procurada, que está na linha 6

ÍNDICE + CORRESP

Se você conhece as fórmulas PROCV e PROCH você sabe que elas só procuram as informações que estão na primeira coluna ou linha, e esse é um dos “problemas” dessas fórmulas que a junção das fórmulas ÍNDICE e CORRESP conseguem resolves. Vamos ver isso agora na prática.

Aqui queremos descobrir qual é a quantidade de venda de acordo com a data. Vamos ver como vamos fazer isso com a junção das fórmulas índice e corresp.

Primeiro, começamos com a fórmula índice. Definimos a matriz como sendo a coluna A, pois é ali que teremos a informação que queremos como retorno. Em seguida, precisamos saber qual o número da linha, por isso utilizamos a fórmula corresp, definindo o valor procurado que no caso é  a data, depois onde a data vai ser procurada que é da coluna B e depois colocamos o número zero para especificar que queremos uma informação exata. Com isso nossa fórmula ficou da seguinte forma

=ÍNDICE(A:A;CORRESP(D2;B:B;0))

E com isso nos foi apresentado a quantidade de vendas da data especificada. 

MAIS UM EXEMPLO...

Dessa vez, nosso exemplo será com uma tabela disposta da horizontal. Você verá que a estrutura será exatamente a mesma e não teremos muitas dificuldades. Observe a tabela abaixo:

Nesse caso, a lógica é a mesma, a diferença é que ao invés de selecionarmos as colunas, selecionamos as linhas. Veja:

Primeiro definimos a matriz da fórmula índice como sendo a linha 1; depois para saber em qual coluna estaria a informação abrimos a fórmula corresp. Nela, o valor procurado ficou sendo a data que se encontra na célula B4, a matriz sendo a linha 2 e no final o 0 para indicar que queremos o valor exato. Com isso nossa fórmula ficou da seguinte forma:

=ÍNDICE(1:1;CORRESP(B4;2:2;0))

Veja o resultado:

E com isso finalizamos aqui os exemplos de uso dessas duas fórmulas que são tão importantes, mas que pouca gente conhece. Se você gostou e se foi novidade pra você, deixa um comentário pra gente.

Até a próxima!!

Curtiu o conteúdo? Compartilhe!

Posts Recentes:

TETRA EDUCAÇÃO 2022 ©
TODOS OS DIREITOS RESERVADOS